Module 1: Student Activity
Identifying Potential Buyers & Customers Before we get into working with Microsoft Dynamics 365 for
Customer Engagement, let’s do some research on potential business and customer that you might be
able to leverage. When identifying who to target as an organization it is important to identify clients that
are a good fit for your organization. There are several factors that can determine if a potential customer
is a good fit.
These can include:
• The Company culture (Core business values, business strategies, and over business approach)
• The team that is responsible to driving business directions and decisions
• Financials
• Industry trends
• Company Position in Industry
Before working with any customer, it is important to do some discovery to better understand who they
are. This way you will be better prepared when you get in front of them to help them build a customer
engagement solution that is based on their current business needs (pain points, etc.). To better
understand this process, you will be researching different organizations that you might likely engage
with if you were selling or offering a solution.
Tasks Required to Complete this Exercise
• Identify and make note of a Business you might work for that sells Products and / or Services
o Identify what those Products or Services would be
o Identify what type of customer you would sell the product or service to
▪ Consider Industry.
• Identify 2 potential real businesses that you might engage if you were selling your product or
service.
o For each business, identify the following:
▪ Full Company Name
▪ Address
▪ Phone Number
• Identify two different people at each business that would be considered as good contacts.
o For each contact, identify the following
▪ Full Name
▪ Phone Number
• Identify two pieces of information (company culture, recent news item, etc.) that would good to
know or potentially leverage during a first meeting with the customer.

Data Capture Sheet
Business Type:

Product / Services Offered

Target Customer Profile

Business 1
Address
Phone
Contact 1:
Address:
Phone:
Contact 2:
Address:
Phone:
Key Company Info 1

Key Company Info 2

Business 2
Address
Phone
Contact 1:
Address:
Phone:
Contact 2:
Address:
Phone:
Key Company Info 1

Key Company Info2

Module 2: Student Activity
Dynamics 365 for Service
Scenario
Since HCL is a professional services company, most of their profits come from the support services that
they offer to their customers. HCL offers help desk services to their customers during normal business
hours of 8 to 5. Additionally, they provide their preferred customers with 24-7 support.
Their preferred customers are broken down into three different levels:
• Gold: Highest Priority customers with a guaranteed 15-minute response time.
• Silver: Customer are guaranteed a callback from a customer service agent in 1 hour
• Bronze: Customers are entitled to 24/7 support and a 2-hour agent response time.
HCL has identified 3 areas that they would like to focus their attention on:
1. Customer Service Representatives need a centralized interface to manage daily caseloads.
Each customer service representative, should have a centralized dashboard that they can access
that shows the representatives daily workloads. The dashboard should contain the following
information.
•
•
•
•

A list of all the open cases that they are currently assigned to them.
A list of all the open Activities assigned to them.
Cases by Origin
Cases by Priority

Agents can take cases from either new of existing customers. Agents should be able to easily
identify if the customer is new or existing prior to creating a case. If the customer is an existing
customer, they can create the case directly. If the customer is a new client, they must first
create a new record for the customer and then, create a case for them.
Scenario: A new customer name “Dennis Smith” who works for Coho Consulting has just
contacted HCL about the following issue:
• A network backup from the previous evening has failed.
Tasks to Accomplish in this Exercise:
• Add a new account for Coho Consulting
• Add a contact record from Dennis Smith to Coho Consulting
• Create a new case for Coho Consulting with the following information
▪ Origin: Phone
▪ Title: Network backup Failed
▪ Contact: Dennis Smith.
▪ Product: leave blank
▪ Entitlement: leave blank
▪ Priority: High

1.

Add a new account for Coho Consulting
• Go to Sales > Accounts.
• Choose New.
• Fill in your information. Use the handy tooltips as a guide.
• Click Save.

2.

Add a contact record from Dennis Smith to Coho Consulting
• Locate the Contacts Sub-Grid
• Click the + to add a new contact
• Fill the contact information into the Contact Quick Create form
• Click Save

3.

Create a new case for Coho Consulting
• Go to Service > Cases.
• Click New Case.
• Set the Case title field to “Network Backup Failed”
• Set the Customer field to “Coho Consulting”.
• Set the Contact field to “Dennis Smith”.
• Set the Origin field to “Phone”.
• Click Save

HCL generally bills their customers based on the total amount of time an agent spends on a
call. The total time spent is a summary of all the activities attached to a specific case. It is
important that all activities related to the case are documented as they work through the calls.

Scenario: After doing some research, the agent identifies that the problem is because the
previous day was a holiday. Because it was a holiday, the previous back-up media was not
replaced. The backup will not overwrite media that was written to in the last 48 hours.
Since no business was conducted on that day, they can skip the back-up job.

Tasks to Accomplish in this Exercise:
• Add an incoming phone call activity from Dennis Smith to the case
▪ Set the duration to 15-minutes
▪ Add the following notes:
• Initial call from Dennis to report the discovery of a failed backup
• Add a task called research problem to the case
▪ Set the duration to 20-minutes
▪ Add the following description:
• Because it was a holiday, the previous back-up media was not

replaced. The backup will not overwrite media that was written to in the
last 48 hours.
• Initial call from Dennis to report the discovery of a failed backup

• Add an outgoing phone call activity to Dennis Smith task called inform Dennis on

Resolution
• Set the duration to 15-minutes.

1.

Add an incoming phone call activity from Dennis Smith to the case
• Locate Activities
• Choose Add Phone Call.
• Set the duration to 15-minutes
• Add the following notes:
• Initial call from Dennis to report the discovery of a failed backup
• Click OK.

2.

Add a task called research problem to the case
• Locate Activities
• Choose Task.
• Set the duration to 20-minutes
• Add the following notes:
• Because it was a holiday, the previous back-up media was not
replaced. The backup will not overwrite media that was written to in
the last 48 hours.
• Click OK.

3.

Add an outgoing phone call activity to Dennis Smith task called inform Dennis of
Resolution
• Locate Activities
• Choose Add Phone Call.
• Set the duration to 15-minutes
• Add the following notes:
• Called Dennis to inform him on the Resolution
• Click OK.

Once a case has been resolved, the agent needs to resolve the case. When a case is resolved,
they need to note in what they did to resolve the case. All the time they spent working on the
case activities also need to be accounted for.
Tasks to Accomplish in this Exercise:
• Ensure that all case related activities are completed
• Resolve the case
▪ Add any necessary details.
1.

Ensure that all case related activities are completed
• Open each Activity on the Case
• Click Mark Complete

2.

Resolve the case
• On the command bar, click Resolve case.

•
•
•

In the Resolve Case dialog box, select the Resolution Type list, choose how the case
was resolved.
In the Resolution box, type a short explanation of the resolution.
Click Resolve.

2. Several Queues that can be used for handling routing
HCL will need 4 queues that they can use to route cases for agents to work on. Those 4 queues
are as follows:
•
Gold:
•
Silver:
•
Bronze:
•
Standard:
When a new case is created the service level of the case needs to be captured on the
case. Based on the Service Level, the case should be routed to the correct queue when the
agent selects the Save and Route button. A rule to allow this behavior is needed that does the
following:
•
•
•
•

Routes any cases with a Service Level of Gold to the Gold Queue:
Routes any cases with a Service Level of Silver to the Silver Queue:
Routes any cases with a Service Level of Bronze to the Bronze Queue:
Routes any cases that do not have a Service Level Defined to the Standard Queue:

Tasks to Accomplish in this Exercise:
•
•

Create 4 Queues in the application: Gold, Silver, Bronze, Standard
Create a routing rule that routes cases to the appropriate queue based on the
Service Level of the case:

1.

Create 4 Queues in the application: Gold, Silver, Bronze, Standard
• Go to Settings > Service Management.
• Choose Queues.
• To create a new queue, click New.
• Enter the name of the Queue.
• Click Save.

2.

Create a routing rule that routes cases to the appropriate queue based on the Service
Level of the case:
• Go to Settings > Service Management.
• Click Routing Rule Sets.
• Click New.
• Call the Rule Case Routing
• Click Save.
• In the Rule Items section, click the Add Rule Item button + to specify
conditions for routing cases to a queue.

•

•

In the Rule Item form, type a descriptive name for the rule item For
example: Gold.
• Under Rule Criteria in the If Conditions section, specify the conditions
for which the case will be routed. For example, Case – Service Level –
Equals - Gold
• Under Then Conditions, specify the queue to route the case to. For
example: Select the Gold Queue
• Click Save & Close
• Repeat for each Queue you want to route items to
In the Routing Rule Set record, click Activate.

Scenario: Coho Consulting has just become a gold customer with your company. Dennis Smith
has contacted you about a printer problem that he is having.
• They are having a problem with a printer that was recently installed, and a case needs to be
logged in the system
• Because they are a Gold customer, the case needs to be routed to Gold queue.
• You need to find the case and Pick it so you can work on it.

Tasks to Accomplish in this Exercise:
•
A new case called Printer Issue needs to be logged into Dynamics 365
•
The case needs to be routed the Gold Queue
•
You need to locate the case in the Gold Queue, and Pick it so you can work on it.
1.

A new case called Printer Issue needs to be logged into Dynamics 365
• Go to Service > Cases.
• Click New Case.
• Set the Case title field to “Printer Issue”
• Set the Customer field to “Coho Consulting”.
• Set the Contact field to “Dennis Smith”.
• Set the Origin field to “Phone”.
• Set the Service Level Field to “Gold”.
• Click Save

2.

The case needs to be routed the Gold Queue
• One the Command Bar, click Save & Route.

3.

You need to locate the case in the Gold Queue, and Pick it so you can work on it.
• Go to Service > Queues.
• Select a view and a filter to see the items that you want.
• To see all cases from the selected queue, in the View list, click All Cases
in Selected Queues.

•

• In the Queue list, choose the Gold Queue.
Select the case or item that you want to work on, and on the command bar,
click Pick.

Module 3: Student Activity
Self-Service Scenario
HCL has a lot of agents that have been with them for a very long time. These agents have built up a lot
of tribal knowledge. Over the next several years many these senior customer service agents are going to
be retiring, or moving on to different positions. HCL want to ensure that they can keep the and
preserve the knowledge that these agents have for the future in a central knowledge repository.
This repository should be accessible by all their customer service agents, and potentially customers
though some type of portal offering. It is important that agents can quickly and efficiently locate
knowledge and communicate with customers. They would like this ability to be directly accessible on
case records.
it is also important to note that for many of HCL’s customers, English is not their primary
language. Articles need to be able to be sent to customers in their preferred Language.
One of the products the HCL gets a lot of calls on is Office 365. Many users at HCL’s customers are not
sure how to accomplish specific tasks in these applications. One of the biggest issues that people
contact HCL about is how to create files in Office 365.
You have been asked to create a knowledge article that explains to users how to create files in Office
365.
Tasks to Accomplish in this Exercise:
•
•
•

1.

Create a new knowledge base article “Create Files in Office 365”
Add both an English and Spanish version
Approve and publish both versions of the article, and set them to expire in one year from today.

Create a new knowledge base article “Create Files in Office 365”
• Click the down arrow next to Dynamics 365
• Select Customer Service Hub
• In the Customer Service Hub sitemap, go to Service > Knowledge Articles.
•

On the command bar, select New.

•

In the Article Content section, fill in the following details:
• Title: Create Files in Office 365
• Keywords: Office 365
In the Content section, add the content for your knowledge article.
• You can use the information in the following Link to populate the content of the
Article:

•

•

•

https://support.office.com/en-us/article/Video-Create-save-and-open-files5786b4fc-9265-4490-b4b7-3324579ea260?wt.mc_id=otc_basics&ui=enUS&rs=en-US&ad=US#ID0EAABAAA=Try_it!
Select Save.

2.

Add both an English and Spanish version
• On the Article, click the Translate button
• Select Spanish – United States for the Language
• Click Create
• Note: You would need to populate the Spanish contents of the article into the
application. For this Exercise just put Spanish Version at the beginning of the
Article contents.
• Select Save

3.

Approve and publish both versions of the article, and set them to expire in one year from today.
• On the Spanish Version of the Office 365 Article, click Approve
• Close the Spanish Version
• Open the English version of the Article, and click Approve
• On the command bar, click Publish.
• Choose to Publish it Now
• Select an expiration date 1 year from today
• Choose to publish approve translated versions.
• Click Publish

Scenario: Coho Consulting has just hired a new employee. Jane Martin has just contacted you
because she is not sure how to create a file in Microsoft Excel.
You need to help Jane with here problem by doing the following:
• Adding Jane as a contact for Coho Consulting
• Adding a gold level case for Coho Consulting with Jane as the contact to the system for the
office issue she is having
• Ensure the case is routed to the correct queue
• Use the knowledge base to resolve the Office 365 Issue
• Attach the appropriate knowledge article to the case
• Resolve the case

BEFORE YOU BEGIN: Be sure to close out of Customer Service Hub and open Dynamics 365
with the traditional Web Client
Tasks to Accomplish in this Exercise:
•
Add Jane as a contact for Coho Consulting
•
Create a gold level case for Coho Consulting with Jane as the contact for the office issue
she is having
•
Route the case is routed to the Gold queue
•
Use the knowledge base to resolve the Office 365 Issue

•
•

Attach the appropriate knowledge article to the case
Resolve the case

1.

Add Jane as a contact for Coho Consulting
• Open the Coho Consulting Account record
• Locate the Contacts Sub-Grid
• Click the + to add a new contact
• Fill the contact information into the Contact Quick Create form
• Click Save

2.

Create a gold level case for Coho Consulting with Jane as the contact for the office issue she
is having
• Go to Service > Cases.
• Click New Case.
• Set the Case title field to “Cannot Create Office 365 Document”
• Set the Customer field to “Coho Consulting”.
• Set the Contact field to “Jane Martin”.
• Set the Origin field to “Phone”.
• Set the Service Level Field to “Gold”.
• Click Save

3.

Route the case is routed to the Gold queue
• One the Command Bar, click Save & Route
• Go to Service > Queues.
• Select a view and a filter to see the items that you want.
• To see all cases from the selected queue, in the View list, click All Cases in
Selected Queues.
• In the Queue list, choose the Gold Queue.
• Select and open the Office 365 case

4.

Use the knowledge base to resolve the Office 365 Issue
• Click KB Records
• Select the Create Office 365 Records article

5.

Attach the appropriate knowledge article to the case
• Click the Link button

6.

Resolve the case
• On the command bar, click Resolve case.
• In the Resolve Case dialog box, select the Resolution Type list, choose how the case
was resolved.
• In the Resolution box, type a short explanation of the resolution.
• Click Resolve.

Module 4: Student Activity
Actionable Analytics Scenario
Reporting and analytics are also very important to HCL. Agents need to easily see what they have done,
and what is assigned to them from a central point. Managers need to quickly identify trends happening
in their call centers, and make business decisions based on those trends. They also want the flexibility
to analyze data using a variety of tools.
These tools could include:
•
Dynamics 365 out of the box reporting functionality
•
Dynamics 365 charts or dashboards
•
Microsoft Excel
•
Power BI.
HCL has identified two main areas that they would like to focus on for analytics:
1.

Quickly Analyze Data with Microsoft Excel

Many of HCL’s employees use Microsoft Excel for the reports use daily. They are very
comfortable with it, and can easily create the items they need. Several of these power users
would like to be able to take information from Dynamics 365 and put it into Microsoft Excel.
Scenario: Many of HCL’s employees use Microsoft Excel for analytics and working through
customer information. HCL wants to ensure that the Excel Template is easily accessible by
employees in Dynamics 365.
You have been asked to create an Excel template that other HCL employees will be able to easily
access from inside Dynamics 365. The template should include the following:
•

Based on the Case entity in Dynamics 365 and include the following columns: Case Title,
Priority, Origin, Customer, Status Reason, and Created On
The Template should include a Pivot table that provides the number of cases by Origin.
It should also include a Pie Chart based on the Pivot Table
A slicer based on the priority should be created from the Chart

•
•
•

Once the template has been created, upload it back into Dynamics 365 so it can be used by
other users in the application.
Tasks to Accomplish in this Exercise:
•
Create an Excel Template based on the Case entity that meets the criteria outlined in the
scenario.
•
Upload the template into Dynamics 365 for use by other employees
1.

Create an Excel Template based on the Case entity that meets the criteria outlined in the
scenario.
•

Navigate Service > Cases

•
•

•
•
•

Select Excel Templates, and click Create Excel Template
Ensure that it is being displayed as follows:
• Filter by Entity: Case
• Used Saved View: My Active Cases
Click Download File
Open the file that you just created
Create a Pivot Table from the case data
• Select all the data in the Excel file
• Select the Design tab
• Click Summarize with Pivot Table
• Make sure to place the table in a New Worksheet
• Click OK
• Drag the Origin field to the Rows section
• Drag the Case Title to the Values section

•

Create a Pie Chart based on the Pivot Table
• Click inside the Pivot Table
• Click the Insert Tab
• Select a 2d Pie-Chart
• Place the Pie-Chart next to the Pivot Table

•

Add a Slicer based on Priority
• Click the Pie-Chart
• Click the Analyze tab
• Click the Insert Slicer button
• Select the Priority Field
• Click OK
• Position the Slicer below the Pivot Table

Your completed Excel Template should look like the image below

•
2.

3.

Save the Excel Template to your Desktop

Upload the template into Dynamics 365 for use by other employees
• In Dynamics 365, navigate Service > Cases
• Select Excel Templates, and click Create Excel Template
• Click the Upload button
• Click Browse and locate the Excel Template you just created
• Click Upload
• Name the File “Case Breakdown by Channel”
• Click the Save button
• Press F5 to reload the application
• Select Excel Templates, Choose Case Breakdown by Channel, Click Open in
Excel Online

Agents need a central view that they can access to view daily activities
You are looking for a more streamlined way to manage your cases and daily activities. you
would like to have a centralized dashboard that you can access that displays specific information
related to your job requirements.
The dashboard should contain the following information.
•
•
•

A list of all the open cases that they are currently assigned to them.
A list of all the open Activities assigned to them.
Cases by Origin

•

Cases by Priority

Tasks to Accomplish in this Exercise:
•

1.

Create a new dashboard that called “Case and Activity Management”.
▪ Add a list of open Cases to the dashboard
▪ Add a list of your open Activities to the dashboard
▪ Include the Cases by Origin Chart
▪ Include the Cases by Priority Chart

Create a new dashboard that called “Case and Activity Management”.
• Navigate to Service > Dashboards
• Click New
• Select 2-Column Regular Dashboard, click Create
• Name the Dashboard “Case and Activity Management”
• Click the Insert List Icon on one of the Tiles
• Set Record Type to Cases, and View to My Active Cases
• Click Add
• Click the Insert List icon on another Tile
• Set Record Type to Activities, and View to My Open Activities
• Click Add
• Click the Insert Chart icon on another Tile
• Set Record Type to Cases, View to My Active Cases, and Chart to Case Mix
(By Origin)
• Click Add
• Click the Insert Cart icon on the last Tile
• Set the Record Type to Cases, view to My Active Cases, and Chart to Case
Mix (By Priority)
• Save & Close the Dashboard
• Press F5 to reload the application
• Click the down arrow next to the Dashboard Name
• Under My Dashboards, select Case and Activity Management

Module 5: Student Activity
Field Service
Scenario
Many times, HCL will have to dispatch technicians on-site to solve customer issues. The reasons that
technicians are dispatched can vary. Many times, it is because a call center agent was not able to
resolve a client’s issue remotely, and now require a technician onsite. Other times, a customer will call
directly to request service.
Many devices HCL install for their clients are Internet of Things (IoT) enabled devices. These devices
automatically report their status, any specific issues, or anomalies they may encounter. HCL wants to
be able to log these issues, and potentially schedule service calls from them.
Most of the services that they provide for their customers have very specific procedures that the
technicians must follow when on site. Since requests for service could potentially be created by most
people in the company, they want to minimize the chance for errors and ensure that all the necessary
products, services, and tasks needed for a ticket are being automatically assigned when a ticket is
created.
Once a ticket has been created it should be able to be scheduled. Work Orders can be scheduled in one
of two ways. The first is manually by a central dispatcher who will use a schedule calendar to identify
who is available and schedule them accordingly. For people who are not dispatchers, they should be
able to easily identify qualified technicians directly from the Work Order itself, and then schedule them
as needed.
HCL has identified three scenarios that it needs assistance with:
1. Provide staff members the ability to create and schedule a Work Order
HCL provides remote support and on-site services for their customers. When someone needs
to schedule a service request for a customer, a Work Order is created. A Work Order could
potentially be multiple staff members. Since many of the staff members may not be familiar
with everything that is needed or required for a Work Order, HCL wants to ensure that Items are
automatically populated on a work order based on what it is.
Scenario: when a Work Order for a security system installation is created, the Staff Member
creating it should be able to select Security System Installation and have the following auto
populate the following:
• Each task that the service technician needs to accomplish. Typically, a Security System
Install includes 5 different tasks. Each task should also include an estimated duration that
will roll up to provide an overall estimated duration for the security system install.
•

All Products and/or Services that will be used in the install. All security installs contain a
minimum of 4 cameras, and one main controller. Depending on the size of the install
additional controller may need to be added.

•

It is required that any technicians who will be performing security system installs have
specific skills and certifications. Technicians without those skills should be prevented from
being scheduled.

Once the ticked is created, the staff member who is creating the ticked should be able to easily
identify potentially qualified technicians who have availability during the time chosen on the
Work order.
Technicians should be recommended based on:
•
The required skills that were noted on the Work Order
•
The time windows that were noted on the Work Order
•
The location of the Work order
Once a technician is identified, they should be scheduled with a single click of a button.

2. Customer Service Reps should be able to escalate cases to Work Orders for a Dispatcher to
schedule:
HCL provides remote support and on-site services for their customers. Most issues that come
into the organization start as Help Desk calls. Call center agents can resolve about 90 percent of
calls coming in over the phone or remotely. Sometimes a call cannot be remotely resolved and a
technician needs to be dispatched. The actual dispatching of the technician is done by HCL’s
dispatching agent.
Scenario: David, is currently working with a customer on a fan issue with one of their security
system cameras. Many times, these issues can be resolved over the phone, but this time it
cannot be.
•

David needs to be able to convert the case he is working on to a Work Order so it can be
scheduled by Lisa.

After the Work Order is created Lisa the dispatcher needs to be able to quickly schedule the
Work Order in the system.
Scenario: Lisa will use a central schedule board that will show all the unscheduled Work Orders
in the system as well as all the resources that could be potentially scheduled.
She needs to be able to filter the board to find availability based on the customer’s location, and
the required skills that are defined on the Work Order.

3. Generate alerts from IoT enabled devices, create Work Orders from the alerts, and
schedule the Work Order:

Many of the products that HCL install for their customers are IoT devices (devices that are
connected and communicate with the internet). One of the systems that they install are IoT
enabled heating systems. These systems will report back when there is an issue with a specific
item such as a temperature sensor is broken or something similar.
When an alert from one of these devices is triggered, HCL wants to be able capture these alerts in
Dynamics 365. Once captured in Dynamics 365, HCL should be able to do the following:
•
•
•
•
•
•

View the alert that was generated by the device.
Remotely interact with the device to perform basic tasks, like resetting the device or
sending test commands to the device.
Convert any alert that is generated to a Work Order, if the technician is unable to
resolve the issue remotely.
Use the schedule board to identify and schedule a qualified technician for the job.
Provide status updates to customers through e-mail or SMS messages.
Technicians receive their scheduled items on a mobile device. The technician should be
able to:
• See a detailed schedule that shows all the tickets that they have been scheduled
for.
• Open a map that provides the locations for all the tickets they were scheduled
for.
• Easily provide status updates on the ticket such as when they are traveling,
working on, or completing a ticket.
• Easily see all tasks that are needed on the ticket and quickly check them off as
they are completing them.
• Take any pictures as needed
• Capture customer signatures directly from their mobile device.

